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Smart Camera hangs after a failed attempt to connect to a remote server

Problem:
The camera "hangs" 100 seconds after a failed attempt to connect to a remote server.

Cause:
According to the RFC TCP/IP standard it is not possible to reduce the OPT_CONNECT_TIMEOUT below 100s.

Solution:

  1. Use VCRT_ping() to establish if the remote server is active.
  2. Call connect() to connect to the remote socket if VCRT_ping() is successful.

Case 1:
The remote server is active, but not the corresponding port/socket.

  • VCRT_ping() is successful
  • calling connect comes back directly with error code "0x636 (connection reset by peer)"

Case 2:
IP not there and no corresponding port.

  • VCRT_ping() not successful
  • don't execute connect()

Case 3:
IP exists and server with corresponding port is active.

  • VCRT_ping() is successful
  • calling connect() is successful

From VCRT 5.26 camera OS please refer to attached demo program. (Please log in first to be able to download the attached demo program.)

Update from VCRT 5.28:
TCP/IP: TCP SEND and CONNECT TIMEOUT can now be lowered via set of socket options to 1000 (send) and 1800 (connect) milliseconds.

 

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